Универсальная идентификация элемента (1С, 8.1, Язык программирования, Справочники)

Функция ИдентификацияЭлемента(УказанноеЗначение, НаименованиеСправочника, СчетчикПоСтрокам, СчетчикПоЛистам, ПоКоду = Ложь, Создавать = Ложь)
    НайденныйЭлемент = Справочники[НаименованиеСправочника].ПустаяСсылка();
    // найдем элемент
    Если ЗначениеЗаполнено(УказанноеЗначение) Тогда
        // попробуем отыскать указанный элемент по коду или по наименованию
        Если ПоКоду Тогда
            НайденныйЭлемент = Справочники[НаименованиеСправочника].НайтиПоКоду(СокрЛП(УказанноеЗначение));
        Иначе
            НайденныйЭлемент = Справочники[НаименованиеСправочника].НайтиПоНаименованию(СокрЛП(УказанноеЗначение), Истина);
        КонецЕсли;
        Если НЕ ЗначениеЗаполнено(НайденныйЭлемент) И НЕ Создавать Тогда
            Сообщить("Не удалось найти указанный элемент "+ УказанноеЗначение + " в справочнике """+НаименованиеСправочника+"""! Строка файла: " + СчетчикПоСтрокам + " . Лист: " + СчетчикПоЛистам + ".");
        КонецЕсли;
    КонецЕсли;
    Возврат НайденныйЭлемент;
КонецФункции // ИдентификацияЭлемента() 

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.