Отчет по номенклатуре на 8.1, написанный в стиле 7.7 (1С: 8.1: Программисту: Язык программирования)

Вопрос Отчет по номенклатуре на 8.1, написанный в стиле 7.7
Ответ

    // Отчет по номенклатуре на 8.1 в стиле 7.7
    // формирование табличного документа
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СписокНовойНоменклатуры_СписокНовойНоменклатуры";

    //Макет = ПолучитьОбщийМакет("ИмяМакета");
    Макет = ПолучитьМакет("СпНовойНоменклатуры");

    Обл        = Макет.ПолучитьОбласть("Заголовок");
    ТабДокумент.Вывести(Обл);

    НПП     = 0;
    Обл        = Макет.ПолучитьОбласть("Строка");

    Для Каждого СтрокаТаблицы Из ТЗСообщений Цикл
        Если ЗначениеЗаполнено(СтрокаТаблицы.ДобавленнаяНоменклатура) Тогда

            НПП = НПП + 1;

            //Обл.Параметры.НаименованиеНомер       = "ПЛАТЕЖНОЕ ПОРУЧЕНИЕ № " + НомерПечать;
            Обл.Параметры.НПП                                    = НПП;
            Обл.Параметры.Ссылка                                = СтрокаТаблицы.ДобавленнаяНоменклатура.Ссылка;
            Обл.Параметры.ПометкаУдаления                        = СтрокаТаблицы.ДобавленнаяНоменклатура.ПометкаУдаления;
            Обл.Параметры.Предопределенный                        = СтрокаТаблицы.ДобавленнаяНоменклатура.Предопределенный;
            Обл.Параметры.Родитель                                = СтрокаТаблицы.ДобавленнаяНоменклатура.Родитель;
            Обл.Параметры.ЭтоГруппа                                = СтрокаТаблицы.ДобавленнаяНоменклатура.ЭтоГруппа;
            Обл.Параметры.Код                                    = СтрокаТаблицы.ДобавленнаяНоменклатура.Код;
            Обл.Параметры.Наименование                            = СтрокаТаблицы.ДобавленнаяНоменклатура.Наименование;
            Обл.Параметры.СтатьяЗатрат                            = СтрокаТаблицы.ДобавленнаяНоменклатура.СтатьяЗатрат;
            Обл.Параметры.Артикул                                = СтрокаТаблицы.ДобавленнаяНоменклатура.Артикул;
            Обл.Параметры.БазоваяЕдиницаИзмерения                = СтрокаТаблицы.ДобавленнаяНоменклатура.БазоваяЕдиницаИзмерения;
            Обл.Параметры.Весовой                                = СтрокаТаблицы.ДобавленнаяНоменклатура.Весовой;
            Обл.Параметры.ВесовойКоэффициентВхождения            = СтрокаТаблицы.ДобавленнаяНоменклатура.ВесовойКоэффициентВхождения;
            Обл.Параметры.ВестиПартионныйУчетПоСериям            = СтрокаТаблицы.ДобавленнаяНоменклатура.ВестиПартионныйУчетПоСериям;
            Обл.Параметры.ВестиУчетПоСериям                        = СтрокаТаблицы.ДобавленнаяНоменклатура.ВестиУчетПоСериям;
            Обл.Параметры.ВестиУчетПоХарактеристикам            = СтрокаТаблицы.ДобавленнаяНоменклатура.ВестиУчетПоХарактеристикам;
            Обл.Параметры.ЕдиницаДляОтчетов                        = СтрокаТаблицы.ДобавленнаяНоменклатура.ЕдиницаДляОтчетов;
            Обл.Параметры.ЕдиницаХраненияОстатков                = СтрокаТаблицы.ДобавленнаяНоменклатура.ЕдиницаХраненияОстатков;
            Обл.Параметры.Комментарий                            = СтрокаТаблицы.ДобавленнаяНоменклатура.Комментарий;
            Обл.Параметры.Набор                                    = СтрокаТаблицы.ДобавленнаяНоменклатура.Набор;
            Обл.Параметры.НаименованиеПолное                    = СтрокаТаблицы.ДобавленнаяНоменклатура.НаименованиеПолное;
            Обл.Параметры.НоменклатурнаяГруппа                    = СтрокаТаблицы.ДобавленнаяНоменклатура.НоменклатурнаяГруппа;
            Обл.Параметры.НомерГТД                                = СтрокаТаблицы.ДобавленнаяНоменклатура.НомерГТД;
            Обл.Параметры.ОсновноеИзображение                    = СтрокаТаблицы.ДобавленнаяНоменклатура.ОсновноеИзображение;
            Обл.Параметры.ОсновнойПоставщик                        = СтрокаТаблицы.ДобавленнаяНоменклатура.ОсновнойПоставщик;
            Обл.Параметры.ОтветственныйМенеджерЗаПокупки        = СтрокаТаблицы.ДобавленнаяНоменклатура.ОтветственныйМенеджерЗаПокупки;
            Обл.Параметры.СтавкаНДС                                = СтрокаТаблицы.ДобавленнаяНоменклатура.СтавкаНДС;
            Обл.Параметры.СтранаПроисхождения                    = СтрокаТаблицы.ДобавленнаяНоменклатура.СтранаПроисхождения;
            Обл.Параметры.Услуга                                = СтрокаТаблицы.ДобавленнаяНоменклатура.Услуга;
            Обл.Параметры.НоменклатурнаяГруппаЗатрат            = СтрокаТаблицы.ДобавленнаяНоменклатура.НоменклатурнаяГруппаЗатрат;
            Обл.Параметры.ВидНоменклатуры                        = СтрокаТаблицы.ДобавленнаяНоменклатура.ВидНоменклатуры;
            Обл.Параметры.ВестиСерийныеНомера                    = СтрокаТаблицы.ДобавленнаяНоменклатура.ВестиСерийныеНомера;
            Обл.Параметры.Комплект                                = СтрокаТаблицы.ДобавленнаяНоменклатура.Комплект;
            Обл.Параметры.ЦеноваяГруппа                            = СтрокаТаблицы.ДобавленнаяНоменклатура.ЦеноваяГруппа;
            Обл.Параметры.ЕдиницаИзмеренияМест                    = СтрокаТаблицы.ДобавленнаяНоменклатура.ЕдиницаИзмеренияМест;
            Обл.Параметры.ДополнительноеОписаниеНоменклатуры    = СтрокаТаблицы.ДобавленнаяНоменклатура.ДополнительноеОписаниеНоменклатуры;
            Обл.Параметры.АнглийскоеНаименование                = СтрокаТаблицы.ДобавленнаяНоменклатура.АнглийскоеНаименование;
            Обл.Параметры.КраткоеНаименование                    = СтрокаТаблицы.ДобавленнаяНоменклатура.КраткоеНаименование;
            Обл.Параметры.ОсновнаяМодель                        = СтрокаТаблицы.ДобавленнаяНоменклатура.ОсновнаяМодель;
            Обл.Параметры.ОсновнаяМарка                            = СтрокаТаблицы.ДобавленнаяНоменклатура.ОсновнаяМарка;
            Обл.Параметры.ОсновнаяМодификация                    = СтрокаТаблицы.ДобавленнаяНоменклатура.ОсновнаяМодификация;
            Обл.Параметры.Производитель                            = СтрокаТаблицы.ДобавленнаяНоменклатура.Производитель;
            Обл.Параметры.РазрешитьПереупаковку                    = СтрокаТаблицы.ДобавленнаяНоменклатура.РазрешитьПереупаковку;
            Обл.Параметры.АртикулСокр                            = СтрокаТаблицы.ДобавленнаяНоменклатура.АртикулСокр;
            //Обл.Параметры.Представление                            = СтрокаТаблицы.ДобавленнаяНоменклатура.Представление;
            Обл.Параметры.НомерСтрокиФайла                        = СтрокаТаблицы.НомерСтрокиФайла;
            Обл.Параметры.НомерЛистаФайла                        = СтрокаТаблицы.НомерЛистаФайла;

            ТабДокумент.Вывести(Обл);
        КонецЕсли;
    КонецЦикла;
    Если НПП > 0 Тогда
        УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, "Созданная номенклатура");
    КонецЕсли;

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.