Создание элемента справочника (1С: 8.1: Язык программирования: Справочники)

Функция СозданиеЭлемента(УказанноеЗначение, НаименованиеСправочника, СчетчикПоСтрокам, СчетчикПоЛистам, ПоКоду = Ложь, Владелец = "")
	НайденноеЗначение = Справочники[НаименованиеСправочника].ПустаяСсылка();
	// создание
	Если ЗначениеЗаполнено(УказанноеЗначение) Тогда
		ИскомыйОбъект = Справочники[НаименованиеСправочника].СоздатьЭлемент();
		Если ПоКоду Тогда
			ИскомыйОбъект.Код		= УказанноеЗначение;
		Иначе
			ИскомыйОбъект.Наименование	= УказанноеЗначение;
		КонецЕсли;
		Если ЗначениеЗаполнено(Владелец)Тогда
			ИскомыйОбъект.Владелец		= Владелец;
		КонецЕсли;
		Попытка
			ИскомыйОбъект.Записать();
			НайденноеЗначение = ИскомыйОбъект.Ссылка;
		Исключение
			Сообщить("Не удалось создать новый элемент "+УказанноеЗначение+" справочника """+НаименованиеСправочника+"""! Строка файла: " + СчетчикПоСтрокам + " . Лист: " + СчетчикПоЛистам + "." + ОписаниеОшибки(), СтатусСообщения.Важное);
			ДобавитьСообщениеВОшибки("Не удалось создать новый элемент "+УказанноеЗначение+" справочника """+НаименованиеСправочника+"""!", СчетчикПоСтрокам, СчетчикПоЛистам, "Важно");
		КонецПопытки;
	КонецЕсли;
	Возврат НайденноеЗначение;
КонецФункции  // СозданиеЭлемента()

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *