Работа с датами в 1с v8 (1С: Программисту)

Вопрос Работа с датами в 1с v8
Ответ

Как явно указать нужную дату

'20050308'
Дата(2005, 1, 1)
Дата(1, 1, 1)
Дата(2005, 1, 1, 10, 29, 50)
ДАТАВРЕМЯ(2005, 01, 01)

Как проверить дату на пустое значение

Если ДатаПроверяемая = Дата(1, 1, 1) Тогда
                   Сообщить("Пустая дата!");
КонецЕсли;

Как сравнить две даты (дни)

Если НачалоДня(Дата1) = НачалоДня(Дата2) Тогда
                   Сообщить("Дни совпадают!");
КонецЕсли;

Как прибавить к дате день, месяц

СледующийДень = ТекущаяДата() + 60 * 60 * 24;
ДобавитьМесяц(Дата(2005, 1, 31), 1);
ДобавитьМесяц(Дата(2005, 2, 28), -1);
КонецМесяца(ДобавитьМесяц(Дата(2005, 2, 28), -1));

Функция ПолучитьДень(ИсходнаяДата, КоличествоПрибавляемыхДней)
    Запрос = НовыйЗапрос("
    |ВЫБРАТЬ
    |    ДОБАВИТЬКДАТЕ(&ИсходнаяДата, ДЕНЬ, &Количество) как Дата";
    Запрос.УстановитьПараметр("ИсходнаяДата", ИсходнаяДата);
    Запрос.УстановитьПараметр("Количество", КоличествоПрибавляемыхДней);
    ВозвратЗапрос.Выполнить().Выгрузить()[0].Дата;
КонецФункции

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *