Управляемый режим блокировки данных (1С: V8: Программисту)

Вопрос Как использовать управляемый режим блокировки данных? Ответ Рассмотрим на примере удаления записей из регистра сведений. 1. В свойствах объекта, для которого используется управляемый режим блокировки данных установить поле «Режим управления блокировкой данных» в значение «Управляемый» (иначе будет сообщение об ошибке «Автоматический режим блокировки недопустим в этой транзакции»). Причем если это делается для документа, то […]

Continue reading


Почему при попытке распечатать на конкретный принтер печать идет на принтер по умолчанию? Команда ТабДокумент.ИмяПринтера не работает (1С: V8: Программисту: Язык программирования)

Вопрос Почему может не работать команда ТабДокумент.ИмяПринтера — при попытке распечатать на конкретный принтер, печать идет на принтер по умолчанию? Ответ Возможно это происходит из-за того, что после присвоения имени принтера командой ТабДокумент.ИмяПринтера где-то ниже идет команда «ИмяПараметровПечати». Эта команда переопределит принтер. Например: ТабДокумент.ИмяПринтера = … … ТабДокумент.ИмяПараметровПечати = … Вообще, эта команда позволяет сохранить […]

Continue reading


Как в 1С v8 изменить запись регистра сведений с помощью метода СоздатьМенеджерЗаписи (1С: 8.1: Программисту: Язык программирования: Регистр сведений)

Вопрос Как в 1С v8 спозиционироваться на конкретной записи регистра сведений и изменить ее? Ответ Метод можно использовать только для регистров, у которых Режим записи установлен Независимый. Вообще, строго говоря, метод СоздатьМенеджерЗаписи() обычно используется для записи новой строки в регистр или для удаления существующей строки. Для редактирования регистра лучше использовать метод СоздатьНаборЗаписи(). Пример см.: Как […]

Continue reading


Отчет по номенклатуре на 8.1, написанный в стиле 7.7 (1С: 8.1: Программисту: Язык программирования)

Вопрос Отчет по номенклатуре на 8.1, написанный в стиле 7.7 Ответ // Отчет по номенклатуре на 8.1 в стиле 7.7 // формирование табличного документа ТабДокумент = Новый ТабличныйДокумент; ТабДокумент.ИмяПараметровПечати = «ПАРАМЕТРЫ_ПЕЧАТИ_СписокНовойНоменклатуры_СписокНовойНоменклатуры»; //Макет = ПолучитьОбщийМакет(«ИмяМакета»); Макет = ПолучитьМакет(«СпНовойНоменклатуры»); Обл = Макет.ПолучитьОбласть(«Заголовок»); ТабДокумент.Вывести(Обл);

Continue reading


Создание элемента справочника (1С: 8.1: Язык программирования: Справочники)

Функция СозданиеЭлемента(УказанноеЗначение, НаименованиеСправочника, СчетчикПоСтрокам, СчетчикПоЛистам, ПоКоду = Ложь, Владелец = «») НайденноеЗначение = Справочники[НаименованиеСправочника].ПустаяСсылка(); // создание Если ЗначениеЗаполнено(УказанноеЗначение) Тогда ИскомыйОбъект = Справочники[НаименованиеСправочника].СоздатьЭлемент(); Если ПоКоду Тогда ИскомыйОбъект.Код = УказанноеЗначение; Иначе ИскомыйОбъект.Наименование = УказанноеЗначение; КонецЕсли; Если ЗначениеЗаполнено(Владелец)Тогда ИскомыйОбъект.Владелец = Владелец; КонецЕсли; Попытка ИскомыйОбъект.Записать(); НайденноеЗначение = ИскомыйОбъект.Ссылка; Исключение Сообщить(«Не удалось создать новый элемент «+УказанноеЗначение+» справочника «»»+НаименованиеСправочника+»»»! Строка файла: […]

Continue reading


Добавление строки в таблицу значений (1С: 8.1: Язык программирования)

Вопрос Пример (шаблон) работы с таблицей значений 1с Ответ Пример: ТЗОшибки = Новый ТаблицаЗначений; ТЗОшибки.Колонки.Добавить(«ФлагВажности»); ТЗОшибки.Колонки.Добавить(«Сообщение»); СтрокаТЗОшибки = ТЗОшибки.Добавить(); СтрокаТЗОшибки.ФлагВажности = Важность; СтрокаТЗОшибки.Сообщение = ТекстСообщения; О создании или добавлении колонок в таблицу значений см. также (там подробнее): http://www.1c-h.ru/?p=1113

Continue reading


Excel — основные методы и конструкции языка, подключение через COM — соединение (1С: v8 и v7: Программисту: Язык программирования)

Вопрос Как осуществить чтение/запись данных из/в Excel на языке 1с (используя COM-объект) Ответ Здесь можно скачать шаблонную обработку, разработанную в среде «1С:Предприятие 8.1» для работы с файлами Excel: [download id=»5″] В обработке осуществляются все основные действия с файлом Excel. Даны подробные комментарии. Можно использовать в качестве шаблона для разработки собственных выгрузок/загрузок в/из Excel.

Continue reading


Перебор записей регистра сведений и изменение их, используя менеджер записи — метод ПолучитьМенеджерЗаписи (8.1: Программисту)

Вопрос Как в 1С 8.1 перебрать записи регистра сведений и изменить их, используя Менеджер Записи? Ответ Покажем на примере. Рег = РегистрыСведений.агКроссыАртикулов; Выборка = Рег.Выбрать(); Пока Выборка.Следующий() Цикл Запись = Выборка.ПолучитьМенеджерЗаписи(); Запись.Прочитать(); Запись.КодАналога = Корректировка(СтрЗаменить(Строка(Выборка.КодАналога),» «,»»)); Запись.КодОригинала = Корректировка(СтрЗаменить(Строка(Выборка.КодОригинала),» «,»»)); Запись.Записать(); КонецЦикла; См. также Как в 1С v8 изменить запись регистра сведений с помощью метода […]

Continue reading


Как организовать перебор записей регистра сведений (1С: 8.1: Программисту)

Вопрос Как перебрать записи регистра? Ответ Рассмотрим на примере: требуется перебирая записи регистра сообщить о расхождении между двумя числовыми параметрами. Как всегда, в 1с масса способов сделать одно и то же действие. Один из них — простой перебор записей регистра.

Continue reading