Создание элемента справочника (1С: v8: Язык программирования: Справочники) — 1C-h
 

Создание элемента справочника (1С: v8: Язык программирования: Справочники)

Функция СозданиеЭлемента(УказанноеЗначение, НаименованиеСправочника, СчетчикПоСтрокам, СчетчикПоЛистам, ПоКоду = Ложь, Владелец = "")
	НайденноеЗначение = Справочники[НаименованиеСправочника].ПустаяСсылка();
	// создание
	Если ЗначениеЗаполнено(УказанноеЗначение) Тогда
		ИскомыйОбъект = Справочники[НаименованиеСправочника].СоздатьЭлемент();
		Если ПоКоду Тогда
			ИскомыйОбъект.Код		= УказанноеЗначение;
		Иначе
			ИскомыйОбъект.Наименование	= УказанноеЗначение;
		КонецЕсли;
		Если ЗначениеЗаполнено(Владелец)Тогда
			ИскомыйОбъект.Владелец		= Владелец;
		КонецЕсли;
		Попытка
			ИскомыйОбъект.Записать();
			НайденноеЗначение = ИскомыйОбъект.Ссылка;
		Исключение
			Сообщить("Не удалось создать новый элемент "+УказанноеЗначение+" справочника """+НаименованиеСправочника+"""! Строка файла: " + СчетчикПоСтрокам + " . Лист: " + СчетчикПоЛистам + "." + ОписаниеОшибки(), СтатусСообщения.Важное);
			ДобавитьСообщениеВОшибки("Не удалось создать новый элемент "+УказанноеЗначение+" справочника """+НаименованиеСправочника+"""!", СчетчикПоСтрокам, СчетчикПоЛистам, "Важно");
		КонецПопытки;
	КонецЕсли;
	Возврат НайденноеЗначение;
КонецФункции  // СозданиеЭлемента()

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Next Post

Отчет на платформе 1С v8, написанный в стиле 7.7 (1С: Программисту, Язык программирования)

Сб Май 22 , 2010
Отчет на v8, написанный в стиле 7.7 Отчет с использованием макета. Расположение в тексте модуля отчета. Макет = ПолучитьМакет("МакетОтветы"); Область = Макет.ПолучитьОбласть("Заголовок"); Область.Параметры.Заголовок = ШаблонАнкеты.Заголовок; Область.Параметры.Опрос = ПредставлениеОпросаДляЗаголовка(РеквизитыОпрос); ТаблицаОтчета.Вывести(Область,1); Область = Макет.ПолучитьОбласть("ПустаяСтрока"); ТаблицаОтчета.Вывести(Область,1); ТаблицаОтчета.НачатьГруппуСтрок("Аннотация"); Область = Макет.ПолучитьОбласть("Аннотация"); ТаблицаОтчета.Вывести(Область,2); ТаблицаОтчета.ЗакончитьГруппуСтрок(); Область = Макет.ПолучитьОбласть("ПустаяСтрока"); ТаблицаОтчета.Вывести(Область,1); ДеревоАнкеты = РезультатЗапроса.Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией); Если ДеревоАнкеты.Строки.Количество() > 0 […]

You May Like