Программисту 1C — Страница 7 — 1C-h
 

Вопрос Что такое ПОЛНОЕ СОЕДИНЕНИЕ в запросе 1C, как оно работает? Ответ Любое «СОЕДИНЕНИЕ» наборов данных, в том числе и «ПОЛНОЕ», дает команду объединить определенным образом два набора данных между собой по некоторому условию (обычно это условие равенства каких-то ресурсов в этих наборах). В случае полного соединения в результирующем наборе […]

Отчет на v8, написанный в стиле 7.7 Отчет с использованием макета. Расположение в тексте модуля отчета. Макет = ПолучитьМакет(«МакетОтветы»); Область = Макет.ПолучитьОбласть(«Заголовок»); Область.Параметры.Заголовок = ШаблонАнкеты.Заголовок; Область.Параметры.Опрос = ПредставлениеОпросаДляЗаголовка(РеквизитыОпрос); ТаблицаОтчета.Вывести(Область,1); Область = Макет.ПолучитьОбласть(«ПустаяСтрока»); ТаблицаОтчета.Вывести(Область,1); ТаблицаОтчета.НачатьГруппуСтрок(«Аннотация»); Область = Макет.ПолучитьОбласть(«Аннотация»); ТаблицаОтчета.Вывести(Область,2); ТаблицаОтчета.ЗакончитьГруппуСтрок(); Область = Макет.ПолучитьОбласть(«ПустаяСтрока»); ТаблицаОтчета.Вывести(Область,1); ДеревоАнкеты = РезультатЗапроса.Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией); Если ДеревоАнкеты.Строки.Количество() > 0 […]

Функция СозданиеЭлемента(УказанноеЗначение, НаименованиеСправочника, СчетчикПоСтрокам, СчетчикПоЛистам, ПоКоду = Ложь, Владелец = «») НайденноеЗначение = Справочники[НаименованиеСправочника].ПустаяСсылка(); // создание Если ЗначениеЗаполнено(УказанноеЗначение) Тогда ИскомыйОбъект = Справочники[НаименованиеСправочника].СоздатьЭлемент(); Если ПоКоду Тогда ИскомыйОбъект.Код = УказанноеЗначение; Иначе ИскомыйОбъект.Наименование = УказанноеЗначение; КонецЕсли; Если ЗначениеЗаполнено(Владелец)Тогда ИскомыйОбъект.Владелец = Владелец; КонецЕсли; Попытка ИскомыйОбъект.Записать(); НайденноеЗначение = ИскомыйОбъект.Ссылка; Исключение Сообщить(«Не удалось создать новый элемент […]

Вопрос Почему иногда все зависает при работе в 1С с Excel Ответ Самая частая причина «прочного зависания» 1С при работе с Excel — это открытое в Excel окно обрабатываемого файла Excel. Прежде чем грешить на написанный код, посмотрите, нет ли открытых окон Excel и закройте их все. Скорее всего, проблема […]

1

Пример (шаблон) работы с таблицей значений 1с Пример: ТЗОшибки = Новый ТаблицаЗначений; ТЗОшибки.Колонки.Добавить(«ФлагВажности»); ТЗОшибки.Колонки.Добавить(«Сообщение»); СтрокаТЗОшибки = ТЗОшибки.Добавить(); СтрокаТЗОшибки.ФлагВажности = Важность; СтрокаТЗОшибки.Сообщение = ТекстСообщения; О создании или добавлении колонок в таблицу значений см. также (там подробнее): http://1c-h.ru/2010/09/20/sozdanie-kolonki-tz/

13

Вопрос Что делать при нестабильной работе 1с? Например, на двух разных компьютерах при внешне одних и тех же условиях программа 1с ведет себя по-разному, выдает какие-то ошибки или как-то некорректно отображает документ и т.п. Ответ Бывает так, что на двух разных компьютерах при внешне одних и тех же условиях программа […]

3

Как в 1С v8 перебрать записи регистра сведений и изменить их, используя Менеджер Записи Покажем на примере. Рег = РегистрыСведений.агКроссыАртикулов; Выборка = Рег.Выбрать(); Пока Выборка.Следующий() Цикл Запись = Выборка.ПолучитьМенеджерЗаписи(); Запись.Прочитать(); Запись.КодАналога = Корректировка(СтрЗаменить(Строка(Выборка.КодАналога),» «,»»)); Запись.КодОригинала = Корректировка(СтрЗаменить(Строка(Выборка.КодОригинала),» «,»»)); Запись.Записать(); КонецЦикла; См. также: Как в 1С v8 изменить запись регистра сведений […]

Как перебрать записи регистра Рассмотрим на примере: перебирая записи регистра требуется сообщить о расхождении между двумя числовыми параметрами. Как всегда, в 1с масса способов сделать одно и то же действие. Один из них — простой перебор записей регистра. #Если Клиент Тогда // выполним контроль приемок РегистрКонтрольПриемки = РегистрыСведений.усКонтрольПриемки; ОтборПоДокументу = […]

3

Вопрос Как установить 1С: Предприятие в клиент-серверном варианте. Раздел содержит практические рекомендации по решению проблем, возникающих при установке и настройке клиент-серверного варианта 1С:Предприятия 8. При подготовке раздела учтен опыт партнеров и пользователей, которым в процессе установки 1С:Предприятия потребовалась дополнительная настройка различных служб Microsoft Windows. Более подробно с материалом можно ознакомиться […]

21

Как в языке запросов 1С отобрать не заполненное значение. Какое условие указать в запросе после ключевого слова «ГДЕ», когда нужно сделать отбор по не заполненным полям? Есть запрос: Запрос.Текст = «ВЫБРАТЬ | усЕдиницыХранения.Ссылка |ИЗ | Справочник.усЕдиницыХранения КАК усЕдиницыХранения Требуется отобрать по условию, что у справочника усЕдиницыХранения реквизит РазрешитьОтборИзРезервнойЗоны пустой Реквизит […]